Use debian stable

Once bullseye is being released we have the right version of
knot-resover in stable.
master
meskio 1 year ago
parent 2fbfc625b1
commit 7005671f65
Signed by: meskio
GPG Key ID: 52B8F5AC97A2DA86
  1. 7
      99testing
  2. 8
      Dockerfile

@ -1,7 +0,0 @@
Package: *
Pin: release a=testing
Pin-Priority: 1
Package: knot-resolver
Pin: release a=testing
Pin-Priority: 500

@ -1,11 +1,7 @@
FROM registry.sindominio.net/debian
COPY 99testing /etc/apt/preferences.d/99testing
RUN echo "deb http://deb.debian.org/debian bullseye main" >> /etc/apt/sources.list && \
apt-get update && \
apt-get install -y --no-install-recommends -t bullseye \
knot-resolver && \
RUN apt-get update && \
apt-get install -y --no-install-recommends knot-resolver && \
apt-get clean && rm -rf /var/lib/apt/lists/*
COPY kresd.conf /etc/knot-resolver/kresd.conf

Loading…
Cancel
Save